Not a valid video URL error after migrating to new server

Hi guys, hope I'm in the right place, I saw that the forums have moved.

I recently migrated my phpfox 3 site to a new server and I'm having a strange problem. Sometimes when a user posts a youtube video it works fine, but other times it still posts the video but the video_embed record never gets created in the database, so when viewing the new page with the video it just shows a "Not a Valid Video URL error".

From testing it a bit I've found that it seems to work fine whenever I post only a few words with the youtube video, but when I post a full title or description, it fails. That leads me to believe it's something to do with a configuration, maybe a timeout or data limit or something. I'm thinking it's probably not a problem with the code because it shouldn't have changed between servers, I'm thinking more likely it's to do with some configuration on the new server? I verified that the basic system requirements are met (php modules, etc) and I tried to configure the php variables the same as well but could have missed anything. Could it be something to do with database config or something? Any help or ideas greatly appreciated!

Thanks!
Dave

p.s. I'm also having problems with the debug functionality so don't have any more info there, when I turn on debug mode I get a message across the site that the site is in maintenance mode.

Comments

  • Just an update on this, still haven't resolved the problem but have some more info. I'm still having issues with debug mode but was able to turn on error logging to file/log with a dev.sett file. Anyway, in the log I found this error related to the event:

    "Query Error:Data too long for column 'title' at row 1"

    This definitely seems like it could be the culprit, but still not sure how to fix this or why it has changed in the migration.

  • Another update, think I've found the solution now. After some more digging and searching I found that the problem was probably to do with the MYSQL configuration after all because the version had been updated in the migration. It seems like the problem was because the strict_table option was enabled in mysql in the new version, and that caused a bunch of problems. For now I have simply disabled strict tables and that seems to have fixed it. I'm guessing I will need to move to strict tables at some point and try to get it working.

  • Are you using cazaratech/phpfoxsolutions? That's who I recommend as I use them too and they would have fixed this for you.

    You'll want to also make sure display_errors is enabled and that you are using all of the required settings. The script is finicky if not on the right server setup. Fox doesn't work with strict mode. You'll need to keep it disabled.

Sign In or Register to comment.