How to change an admin setting when you cant get into admin panel?

edited April 12 in SocialEngine

Somehow redis was turned on ( I didnt turn it on ) in my admin a panel under cache settings and now I get this error

Warning: Redis::pconnect(): connect() failed: Connection refused in /public_html/application/libraries/Engine/Cache/Backend/Redis.php on line 61

I can only get in under development mode and in that mode you cannot turn caching off. anyone know where in the database i can change this admin parameter? Or is it somewhere else?

Comments

  • Go into your files on the server and in application/settings/cache.php change from redis to file. Lines 17-25 and you should make a backup of the cache file first.

    array (
        'File' => 
        array (
          'file_locking' => true,
          'cache_dir' => '/Applications/MAMP/htdocs/fresh/temporary/cache',
        ),
      ),
      'default_file_path' => '/Applications/MAMP/htdocs/fresh/temporary/cache',
    ); ?>
    
    max99
  • Noting that the path for yours will be different than mine. The path I show is for my Mamp install on local.

    max99
  • Thanks that did it. Something to do with redis i believe, ( i had it shut off ) and now my email sever is spitting out 10000's of emails from the site that are months old and it wont stop. Cant figure it out

  • my host is having problems figuring this out and thousands of emails keep getting generated and are months old sent to users. My support for se has run out and they wont look until I upgrade the site. I cant do that right now as that may add another problem on top of this.

    Have you heard of this before and if not do you know of a good SE coder I can get to work on this?

    Thanks Donna

  • Take the site out of development mode if it's in it.

  • yea we finally had to disable the mail system.....all good. =)

  • Glad it's resolved.

Sign In or Register to comment.